Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » strange problem when opening word doc situated in WLS virtual dir (WLS 10.3.3, XP SP2)
strange problem when opening word doc situated in WLS virtual dir [message #521042] Fri, 26 August 2011 00:52 Go to next message
Martin Eysackers
Messages: 80
Registered: October 2005
Location: Belgium
Member
Hi all,

we have a strange problem when opening word doc
situated in C:\Oracle\Middleware\as_1\forms\webutil
we put some word docs there and tried to open from forms using for example web.show_document('http://wp0606:9001/forms/webutil/mug00103.doc', '_blank');
no problem using FF, however in IE8 the word doc is shown in its binary format, this also happens when we try to open the doc in IE8
however when we google and search for instance for a test.doc and then click on this url a file save dialog is shown
that's why we believe that this might be due to a configuration issue of WLS

any help would be greatly appreciated

Kr
Martin
Re: strange problem when opening word doc situated in WLS virtual dir [message #521054 is a reply to message #521042] Fri, 26 August 2011 01:58 Go to previous messageGo to next message
John Watson
Messages: 8319
Registered: January 2010
Location: Global Village
Senior Member
This sounds like a problem with MIME types. If Firefox works, then WLS must be sending the correct MIME type. So you have to configure your browser to launch the correct program for that MIME type. With FF6, it is tools/options/applications, with IE8 it is tools/internet options/programs/set programs/associate.
Re: strange problem when opening word doc situated in WLS virtual dir [message #521055 is a reply to message #521042] Fri, 26 August 2011 02:16 Go to previous messageGo to next message
Martin Eysackers
Messages: 80
Registered: October 2005
Location: Belgium
Member
Hi John,


we can't find tools/internet options/programs/set programs/associate in IE8

it could be the mime-type, but when we open the temporary internet files of IE8 and locate the doc, it says in filetype column : firefox document
in a normal windows explorer window for a doc file, it says word document
when we open the doc file from the IE cache, it opens IE8 showing the word doc in binary format


Kr
Martin
Re: strange problem when opening word doc situated in WLS virtual dir [message #521057 is a reply to message #521042] Fri, 26 August 2011 02:29 Go to previous messageGo to next message
Martin Eysackers
Messages: 80
Registered: October 2005
Location: Belgium
Member
John,


after uninstalling FF, a word doc is shown as an html file type from within the IE8 cache

only PDF files seems to open correctly



Kr
Martin
Re: strange problem when opening word doc situated in WLS virtual dir [message #521074 is a reply to message #521057] Fri, 26 August 2011 04:01 Go to previous messageGo to next message
John Watson
Messages: 8319
Registered: January 2010
Location: Global Village
Senior Member
Quote:
we can't find tools/internet options/programs/set programs/associate in IE8
Then your IE must be different from my IE.
Re: strange problem when opening word doc situated in WLS virtual dir [message #521084 is a reply to message #521074] Fri, 26 August 2011 04:30 Go to previous messageGo to next message
Martin Eysackers
Messages: 80
Registered: October 2005
Location: Belgium
Member
I checked with my collegues, we all have IE8.06 on XP SP2 (32bit)
and none of our laptops have this option
Re: strange problem when opening word doc situated in WLS virtual dir [message #521088 is a reply to message #521084] Fri, 26 August 2011 04:42 Go to previous messageGo to next message
John Watson
Messages: 8319
Registered: January 2010
Location: Global Village
Senior Member
I have IE8.0.6 on Vista. Are you really telling me that is no button for "tools"? And that when you click it, you do not get a drop down menu with "internet options"? And so on?
If IE8 is different in XP, you'll have to find it. Microsoft stopped mainsrtam support for XP two years ago, you know.

[update: just a thought - is your IE configured to show the "command bar"?]

[Updated on: Fri, 26 August 2011 04:43]

Report message to a moderator

Re: strange problem when opening word doc situated in WLS virtual dir [message #521109 is a reply to message #521088] Fri, 26 August 2011 07:24 Go to previous messageGo to next message
Martin Eysackers
Messages: 80
Registered: October 2005
Location: Belgium
Member
we have tools=>internet options=>programs
See the attached file
  • Attachment: IE8.JPG
    (Size: 50.39KB, Downloaded 429 times)
Re: strange problem when opening word doc situated in WLS virtual dir [message #521117 is a reply to message #521109] Fri, 26 August 2011 08:03 Go to previous message
John Watson
Messages: 8319
Registered: January 2010
Location: Global Village
Senior Member
Oh. I get these. A bit different! I am certain that what you need to do is sort out the MIME-to-program associations, but I can't help further. Sorry.
  • Attachment: 1.gif
    (Size: 27.21KB, Downloaded 442 times)
  • Attachment: 2.gif
    (Size: 24.01KB, Downloaded 287 times)
Previous Topic: share OIA instance on two servers loacted on differnt machine [merged 3]
Next Topic: Database Creation on Oracle10gAS
Goto Forum:
  


Current Time: Sun Aug 09 19:13:46 CDT 2020